Project

General

Profile

Actions

Feature #1545

closed

API: Filter entities by types

Added by Bernhard Koschiček-Krombholz over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Category:
API
Target version:
Start date:
2021-07-08
Estimated time:

Description

Andreas asked if it is possible to filter the output of the entities endpoint by types. For Example, show me all artefact, who has the type X and type Y.

Parameter:

/api/0.2/class/E18?type_id=124487&type_id=10832


Related issues 1 (0 open1 closed)

Related to OpenAtlas - Feature #1546: API: New search parameterClosedBernhard Koschiček-Krombholz2021-07-12Actions
Actions #1

Updated by Bernhard Koschiček-Krombholz over 2 years ago

  • Description updated (diff)
Actions #2

Updated by Bernhard Koschiček-Krombholz over 2 years ago

Actions #3

Updated by Bernhard Koschiček-Krombholz over 2 years ago

The problem is, how do we connect these types? Will we get only entities, which has all the selected types, or all entities with at least one of the given types?

Actions #4

Updated by Bernhard Koschiček-Krombholz over 2 years ago

  • Status changed from In Progress to Closed
  • Target version changed from 208 to 6.4.0

The basic functionality is ready to use. Right now, the type_ids will be connected with an OR. The question of how other filter methodes can be used, will be discussed in following ticket: Feature #1546: API: Overall refactor of API parameters.

Actions

Also available in: Atom PDF