Project

General

Profile

Bug #1554

Error at value type view

Added by Bernhard Koschiček-Krombholz about 2 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Low
Category:
Backend
Target version:
Start date:
2021-07-30
Estimated time:
Found in version:

Description

The detail page of value type->dimension->length through a 500 error: https://thanados.openatlas.eu/entity/26189

I think an entity is corrupt.

History

#1

Updated by Alexander Watzinger about 2 months ago

  • Found in version set to 6.4.0
  • Target version set to 6.4.0
  • Status changed from New to In Progress
  • Category set to Backend
  • Project changed from THANADOS to OpenAtlas

Can confirm.
It looks like when creating a sub type of a value type a 'P2' link is also created. When looking at the parent again there is an error because of this wrong link.
I have to look into this some more and will clean up the data once solved but thank you very much for reporting, this is important.

#2

Updated by Alexander Watzinger about 2 months ago

  • Found in version changed from 6.4.0 to 6.3.0

Like assumed the bug is at type creation. When choosing a super the super is linked additional with 'P2'.
I fixed it in the develop branch and added a clean up function in the 6.4.0 upgrade SQL but want to make further test next week just to be save.
Thanks again for spotting and reporting this.

#3

Updated by Alexander Watzinger about 2 months ago

  • Subject changed from OpenAtlas: 500 Error for value type->dimension->length to Error at value type view
#4

Updated by Alexander Watzinger about 2 months ago

  • Status changed from In Progress to Closed

Fixed in develop

Also available in: Atom PDF