Project

General

Profile

Bug #1592

Error at import when using type ids

Added by Sebastian Majstorovic about 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Category:
Data import/export
Target version:
Start date:
2021-10-26
Estimated time:
Found in version:

Description

When an admin tries to import data as a CSV file and the import is unsuccessful, only a generic error message "Error at import" is shown (see attached screenshot). It would be very helpful if admins received a more detailed error message displaying the specific import error, so that they can adjust their CSV file accordingly.


Files

Screenshot 2021-10-26 at 19.15.51.png (42.8 KB) Screenshot 2021-10-26 at 19.15.51.png Screenshot of generic import error message Sebastian Majstorovic, 2021-10-26 19:20
Screenshot.png (49.5 KB) Screenshot.png Alexander Watzinger, 2021-10-27 12:30

History

#1

Updated by Sebastian Majstorovic about 1 year ago

  • Found in version set to 6.5.0
#2

Updated by Alexander Watzinger about 1 year ago

  • File Screenshot.png Screenshot.png added
  • Tracker changed from Bug to Feature
  • Status changed from New to In Progress
  • Assignee set to Alexander Watzinger
  • Target version set to 6.6.0
  • Found in version deleted (6.5.0)

Thank you for reporting and especially for providing a screenshot.

I tested it with the example file (which is linked at the import site) which worked fine.
If we can identify the error it is displayed, not in the error message on top but below, see screenshot. If it is an unexpected error, a generic error message is displayed.
Because of security reasons we don't expose unexpected internal errors in this view so this is the intended behavior and I changed the issue from bug to feature.

Nevertheless I agree that this isn't very helpful in this case and so the question is how to identify the error you encountered and how to proceed.
  • One option is to look into the system logs (Admin -> General -> System log) where you may find additional information. But this is only available for users with the admin role.
  • If you are the system administrator it may be worth to take a look at the web server log files. In Debian using Apache it is called error.log and located, depending on configuration, somewhere in /var/log/apache2.
  • Another option would be to provide the CSV file (or a part of it) which triggers the error. If you don't want to post it in public here feel free to send it with an email to me at

Thank you again for reporting and I hope we can resolve this soon.

#3

Updated by Alexander Watzinger about 1 year ago

  • Found in version set to 6.5.0
  • Tracker changed from Feature to Bug
  • Subject changed from Only generic error message on CSV data import to Error at import when using type ids
  • Status changed from In Progress to Resolved
  • Priority changed from Normal to 3

A big thank you for providing sample data which helped a lot. It turned out it really was a bug when using type ids.
I already pushed the fix in the main branch in case you want to use it soon.

Please let us know if this now works as expected, e.g. just set the issue status to closed.

I also implemented that errors at the import check function are logged too. They were already logged at the main function but the script didn't make it that far. So from now on you should find more information at Admin -> General -> System log in case you encounter errors again.

#4

Updated by Sebastian Majstorovic about 1 year ago

  • Status changed from Resolved to Closed

Thank you so much, this was the fastest bug fix I have ever seen. I tested it and the CSV import works fine now!

#5

Updated by Alexander Watzinger about 1 year ago

  • Target version changed from 6.6.0 to 6.5.1

Also available in: Atom PDF