Project

General

Profile

Actions

Feature #1655

closed

API: Performance improvement

Added by Alexander Watzinger almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Category:
API
Target version:
Start date:
2022-03-15
Estimated time:

Description

Loading information for the CONNEC views takes too long at the moment. This is a good opportunity to look into improving the API (v03) performance.

Actions #1

Updated by Alexander Watzinger almost 2 years ago

Although I assigned this issue to Bernhard who is in charge of the API we can of course look at this together with Andreas and me.

Actions #2

Updated by Bernhard Koschiček-Krombholz almost 2 years ago

It is the old problem, that the relation of the entities need a long time to calculate. I am happy for any help to make this process faster.

Actions #3

Updated by Alexander Watzinger almost 2 years ago

  • Target version changed from CONNEC to 208
  • Project changed from OpenAtlasDiscovery (origin) to OpenAtlas
  • Subject changed from Improved performance to Improved API performance
  • Category set to API

I assume the performance bottleneck is at the API requests and not loading the presentation site after data is available but I can double check with Andi on Monday.
We can than have a look at it together (I and Bernhard) on Tuesday.
Also moving this issue to the OpenAtlas project because this seems to be a more generic OpenAtlas API topic.

Actions #4

Updated by Bernhard Koschiček-Krombholz almost 2 years ago

You don't need to double check, it is an issue of the API. I know where the problem is, but I couldn't find a better solution. And I would be greatful to go through it with you.

Actions #5

Updated by Alexander Watzinger almost 2 years ago

  • Status changed from Assigned to Resolved
  • Assignee changed from Bernhard Koschiček-Krombholz to Andreas Olschnögger
  • Target version changed from 208 to 7.3.0

I merged duplicated tickets, this was the last message of Bernhard to Andi:

@Andi: we improved the API calls. Please try to set the limit to 99999. This should now be significantly faster than serval smaller calls.
CONNEC is already updated to the newest development version.

Actions #6

Updated by Alexander Watzinger almost 2 years ago

  • Subject changed from Improved API performance to API: Performance improvement
Actions #7

Updated by Alexander Watzinger almost 2 years ago

  • Status changed from Resolved to In Progress
  • Assignee changed from Andreas Olschnögger to Bernhard Koschiček-Krombholz

Although much better we still need better performance to e.g. show all case study data on the start page for the CONNEC presentation site.

Actions #8

Updated by Bernhard Koschiček-Krombholz almost 2 years ago

  • Status changed from In Progress to Closed
Actions

Also available in: Atom PDF