Project

General

Profile

Bug #674

Place error occurs during saving

Added by Christof Rauchenberger about 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Low
Category:
Frontend
Target version:
Start date:
2016-04-02
Due date:
% Done:

0%

Found in version:

Description

When you add a new Place, the entry is created even if invalid input causes the "Save" page to display an error.

Steps to reproduce:

1) Place > + Place
2) Enter data:
Name: Tianjing
Site: Settlement
Easting: 118°46′
Northing: 32°03′
Description: As the capital of the brief-lived rebel Taiping Heavenly Kingdom founded by the Taiping rebels in the mid-19th century, Nanjing was known as Tianjing (天京, "Heavenly Capital" or "Capital of Heaven").

3) Click "Save"

The following, mostly empty page will display the message "Sorry, but an error occurred". The cause seems to be the invalid format of easting and northing. The place will still be created.

History

#1 Updated by Alexander Watzinger about 3 years ago

  • Target version set to 2.0.0
  • Found in version set to 1.5.0
  • Category set to Frontend
  • Status changed from New to Assigned
  • Assignee set to Alexander Watzinger

#2 Updated by Alexander Watzinger almost 3 years ago

  • Status changed from Assigned to Closed
  • Target version changed from 2.0.0 to 1.6.0

Error was because of the "118°46′" format.
Fixed for now with only allowing input format like "48.208121". With feature #574 this functionality will move to the map.

#3 Updated by Alexander Watzinger almost 3 years ago

  • Subject changed from Places are created even when an error occurs during saving to Place error occurs during saving

Also available in: Atom PDF