Project

General

Profile

Bug #941

Text in brackets of subtypes disappears when edited

Added by Bernhard Koschicek over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Low
Category:
Frontend
Target version:
Start date:
2018-09-28
Estimated time:
Found in version:

Description

When I edit a custom sub type with a brackets in the name, the brackets with content doesn't appear at the Name field. Confer screenshot for clarity.

Are brackets forbidden in types?


Files

1.png (138 KB) 1.png Before edit Bernhard Koschicek, 2018-09-28 12:48
2.png (124 KB) 2.png Edit Bernhard Koschicek, 2018-09-28 12:48

History

#1

Updated by Bernhard Koschicek over 1 year ago

  • Subject changed from Text in Brackets disappears when edited to Text in brackets of subtypes disappears when edited
#2

Updated by Alexander Watzinger over 1 year ago

  • Category set to Frontend
  • Status changed from New to Closed
  • Assignee set to Alexander Watzinger
  • Target version set to 3.9.0

It's not a bug it's a feature ;)

No, seriously, type names can't include round brackets because they are already used for labels in directed types e.g. "parent of (child of)".

The two alternatives I could think of:

  • use some special character string e.g. "parent of ##!## child of"
  • save the opposite label information somewhere else

But both alternatives would be problematic when loosing the context e.g. the data is imported/used in other systems.

However, since this is not obvious I documented it in the manual and added a link to the type overview.

As always, thanks for reporting!

Also available in: Atom PDF