Project

General

Profile

Feature #1206

API: Show entities of subtypes

Added by Stefan Eichert 7 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Low
Category:
API
Target version:
Start date:
2020-06-07
Estimated time:
(Total: 0.00 h)

Description

By now it is possible to see all entities of a certain type (e55) if this type is selected via the api.

The entities that have this type are linked via: crm:p2_has_type.

We should discuss if we include all entities that have subtypes of this very type (recursively)

Actually each entity that has a subtype of this one also has the superior one...

This also occurs to other entitites e.g places. For example "europe". Not only the places (in our case E18-places and their locations) that are linked directly to "europe" (via has current or former location P53) are in Europe but also the ones that are in subunits (countries, provinces, towns etc.) of Europe.

This is my point for now and I would like to open the discussion. Looking forward to feedback!
Best, Stefan


Subtasks

Question #1270: Administrative Unit and Historical Place get not covered with links or relationshipClosedAlexander WatzingerActions

Related issues

Related to Feature #1331: API: Front end queriesClosed2020-09-07Actions

History

#1

Updated by Alexander Watzinger 6 months ago

  • Target version set to API
#2

Updated by Bernhard Koschicek 6 months ago

Stefan Eichert wrote:

By now it is possible to see all entities of a certain type (e55) if this type is selected via the api.

The entities that have this type are linked via: crm:p2_has_type.

We should discuss if we include all entities that have subtypes of this very type (recursively)

Actually each entity that has a subtype of this one also has the superior one...

This also occurs to other entitites e.g places. For example "europe". Not only the places (in our case E18-places and their locations) that are linked directly to "europe" (via has current or former location P53) are in Europe but also the ones that are in subunits (countries, provinces, towns etc.) of Europe.

This is my point for now and I would like to open the discussion. Looking forward to feedback!
Best, Stefan

So you want every subtypes of a type under the relation tag? The question is, how do we build the tree? It can look like this:

relations: [
{
  label: "Kärnten",
  relationTo: "http://thanados.openatlas.eu/api/0.1/entity/89",
  relationType: "crm:P89_falls_within",
  subtype: [
       {
      label: "Hermagor",
      relationTo: "http://thanados.openatlas.eu/api/0.1/entity/27072",
      relationType: "crm:P89_falls_within",
      subtype: [
      {
        label: "DELLACH",
        relationTo: "http://thanados.openatlas.eu/api/0.1/entity/27111",
        relationType: "crm:P89_falls_within",
        },
        {
        label: "GITSCHTAL",
        relationTo: "http://thanados.openatlas.eu/api/0.1/entity/27088",
        relationType: "crm:P89_falls_within",
        },
        {
        label: "HERMAGOR - PRESSEGGER SEE",
        relationTo: "http://thanados.openatlas.eu/api/0.1/entity/27091",
        relationType: "crm:P89_falls_within",
        },
        {
        label: "KIRCHBACH",
        relationTo: "http://thanados.openatlas.eu/api/0.1/entity/27083",
        relationType: "crm:P89_falls_within",
        },
        {
        label: "KÖTSCHACH - MAUTHEN",
        relationTo: "http://thanados.openatlas.eu/api/0.1/entity/27073",
        relationType: "crm:P89_falls_within",
          subtype: [
          {
            label: "KÖTSCHACH",
            relationTo: "http://thanados.openatlas.eu/api/0.1/entity/27074",
            relationType: "crm:P89_falls_within",
            },
            {
            label: "MAUTHEN",
            relationTo: "http://thanados.openatlas.eu/api/0.1/entity/27075",
            relationType: "crm:P89_falls_within",
          }
          ]
        }
        ]
    },
    {
      label: "Klagenfurt",
      relationTo: "http://thanados.openatlas.eu/api/0.1/entity/26747",
      relationType: "crm:P89_falls_within",
      subtype: [
        {
        label: "KLAGENFURT",
        relationTo: "http://thanados.openatlas.eu/api/0.1/entity/26748",
        relationType: "crm:P89_falls_within",
        }
      ]
    }
  ]
}

]

But the question is, why do we need show everything? As far as I understand APIs, the goal is, that the client can navigate with links through the data, and not that one API page gives you all information. I also think, there can be a issue with the performance, if we always include all the subtypes.

I suppose, you want this data prepered for the front end?

#3

Updated by Stefan Eichert 6 months ago

Hi everyone!
Thanks Berni for the discussion contribution. I think the issue is more a conceptual one that also regards classes etc.
Its not so much about the recursive tree of types or classes but about the entities that are classified/categorised by them.
Per definitionem each entity of a subclass (e.g. of E21 Person) of a certain class (e.g. E39 Actor) is, respectively inherits, all super classes. So each person is at the same time an actor as well as all the superior classes (up to E1). So we should discuss if we show all entitites of all subclasses as well if the API is asked for an entity of a superior class. Same would need to be discussed for types too. If an entity is linked to a certain type, that has a broader term (p127) this entity inherits the broader term too.

From my point of view there are several possible solutions. Each of them should be implemented somehow. For the beginning we should discuss the following:
1. one exact query that only gets the specific results
2. one query that delivers the entitites of the requested class/type/etc. and all entities that are classified via subtypes/subclasses/etc.

I am not sure about performance but if we stick to the idea of the CRM i think version 2 should be default and version one somehow optional.

One example to make it a little bit clearer:
If I want to get all burial sites (and entities of their subtypes) from the api, I would need to
1. ask the API for the json-ld of https://thanados.openatlas.eu/entity/77
2. parse all narrower term relations and get their p2 relations
3. recursively parse them too and their relations via p2
4. then retrieve all the data from the p2 relations and build my data object from them.

So to cut a short story long ;) why not show entities of recursive subunits of types, classes, places, periods etc. in the API relations as they inherit everything that all their superior classes/types are defined of?

best, Stefan

#4

Updated by Alexander Watzinger 6 months ago

Just a little input about performance: if we use what is already implemented:

  • We can access all nodes (types and hierarchical places) from the g object (g.nodes)
  • Every node "knows" the ids of all their supers recursively (node.root)
  • Every node "knows" the id of all sub nodes (node.subs, not recursively)

With classes it works similar (g.classes) except that they only know their direct super. It's a little different because CIDOC CRM is not as strict hierarchical as with our nodes where every node can only have one super.

However, since we already have access to all nodes and all classes in g.nodes and g.classes it's not a performance issue to access them even with recursive functions.

Next step would be to get all related entities. Entity.get_by_class(code) takes only one class as argument. I can rewrite this (make a ticket if you need this) to optional take a list so that we only need one database query to get entities of multiple classes. Of course if there are tens of thousands in the result we will run into performance problems eventually. Christoph said something about paging the results which sounds useful.

Also, I already experimented in OpenAtlas a while ago to load everything (every entity and link) in one go - it didn't go well performance like and I guess that extreme can't be the solution so we have to find some middle ground.

#5

Updated by Alexander Watzinger 6 months ago

  • Status changed from New to Assigned

I renamed and refactored get entities functions at model/entity for easier use in the API. It's already in the development branch on GitHub.

get_by_class_code() now takes a string (e.g. 'E21') or a list of strings
get_by_menu_item() takes one of these strings: actor, event, place, reference, source

Difference is that the first one "blindly" gets all entities with specified class code(s). The other one returns results like you see in the UI overview tables. E.g. with sources you get all 'E33' with the system type 'source content'.
I hope that helps to make these functions easier to use and understand.

#6

Updated by Bernhard Koschicek 5 months ago

Sorry, that this takes quite long. We have to talk about this again at the API meeting.

I have done it for normal entities. But for the Types I encountered the bug #1270. I need to talk with Alex for more insight of the Entity and Link structure.

#7

Updated by Bernhard Koschicek about 2 months ago

#8

Updated by Bernhard Koschicek about 1 month ago

  • Assignee changed from Bernhard Koschicek to Stefan Eichert

In develop there are now two new paths: /api/0.1/node_entities/26294 and /api/0.1/node_entities_all/26294. The first shows, if the id is a node, all connected entities of this node. The second show all entities connected to that node and connected to all subnodes.

Result looks like this:

[
   {
      "id":116984,
      "label":"2 early medieval sherds",
      "url":"http://openatlas.sarfstation.de/api/0.1/entity/116984" 
   },
   {
      "id":107195,
      "label":"Abfallgrube Gst. Nr. 393 Keramik",
      "url":"http://openatlas.sarfstation.de/api/0.1/entity/107195" 
   },
   {
      "id":116800,
      "label":"Atypical sherd without inv. no.",
      "url":"http://openatlas.sarfstation.de/api/0.1/entity/116800" 
   },
   ...
]

This is especially for types. It theoretically works for E53 too, but also includes the subtypes, because they are also linked as place. I will work on that.

Stefan Eichert: is this a list you want? Do you need other details or can you work with that?

#9

Updated by Stefan Eichert about 1 month ago

Hi Berni!
thanks for that. The way you described it, it seems to work. However, can you give me a complete example of both versions just to make sure? E.g. for the (thanados) id 26478?
best, Stefan

#10

Updated by Bernhard Koschicek about 1 month ago

(edit: note relation is now url)

http://openatlas.sarfstation.de/api/0.1/node_entities/26478

[
   {
      "id":116660,
      "label":"Buckles without inv. no.",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/116660" 
   },
   {
      "id":102537,
      "label":"G024F06",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/102537" 
   },
   {
      "id":107523,
      "label":"Grave03-07",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107523" 
   },
   {
      "id":103525,
      "label":"Grave03-08",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/103525" 
   },
   {
      "id":107513,
      "label":"Grave03-09",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107513" 
   },
   {
      "id":107537,
      "label":"Grave04-01",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107537" 
   },
   {
      "id":107545,
      "label":"Grave04-14",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107545" 
   },
   {
      "id":107571,
      "label":"Grave07-01",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107571" 
   },
   {
      "id":108689,
      "label":"Grave08-17",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/108689" 
   },
   {
      "id":99839,
      "label":"Grave08-18",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/99839" 
   },
   {
      "id":107627,
      "label":"Grave08-19",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107627" 
   },
   {
      "id":107691,
      "label":"Grave16-07",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107691" 
   },
   {
      "id":107655,
      "label":"Grave16-11",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107655" 
   },
   {
      "id":108567,
      "label":"Grave1_F2",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/108567" 
   },
   {
      "id":107713,
      "label":"Grave21-03",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107713" 
   },
   {
      "id":107733,
      "label":"Grave22-03",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107733" 
   },
   {
      "id":107325,
      "label":"Inr. 32978",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107325" 
   },
   {
      "id":99313,
      "label":"Inr. 32996 und Inr. 32997",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/99313" 
   },
   {
      "id":93475,
      "label":"no Inv. No.",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/93475" 
   },
   {
      "id":83623,
      "label":"No Inv. No.",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/83623" 
   }
]

http://openatlas.sarfstation.de/api/0.1/node_entities_all/26478

[
   {
      "id":116660,
      "label":"Buckles without inv. no.",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/116660" 
   },
   {
      "id":102537,
      "label":"G024F06",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/102537" 
   },
   {
      "id":107523,
      "label":"Grave03-07",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107523" 
   },
   {
      "id":103525,
      "label":"Grave03-08",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/103525" 
   },
   {
      "id":107513,
      "label":"Grave03-09",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107513" 
   },
   {
      "id":107537,
      "label":"Grave04-01",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107537" 
   },
   {
      "id":107545,
      "label":"Grave04-14",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107545" 
   },
   {
      "id":107571,
      "label":"Grave07-01",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107571" 
   },
   {
      "id":108689,
      "label":"Grave08-17",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/108689" 
   },
   {
      "id":99839,
      "label":"Grave08-18",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/99839" 
   },
   {
      "id":107627,
      "label":"Grave08-19",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107627" 
   },
   {
      "id":107691,
      "label":"Grave16-07",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107691" 
   },
   {
      "id":107655,
      "label":"Grave16-11",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107655" 
   },
   {
      "id":108567,
      "label":"Grave1_F2",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/108567" 
   },
   {
      "id":107713,
      "label":"Grave21-03",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107713" 
   },
   {
      "id":107733,
      "label":"Grave22-03",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107733" 
   },
   {
      "id":107325,
      "label":"Inr. 32978",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107325" 
   },
   {
      "id":99313,
      "label":"Inr. 32996 und Inr. 32997",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/99313" 
   },
   {
      "id":93475,
      "label":"no Inv. No.",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/93475" 
   },
   {
      "id":83623,
      "label":"No Inv. No.",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/83623" 
   },
   {
      "id":89587,
      "label":"73",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/89587" 
   },
   {
      "id":89575,
      "label":"74",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/89575" 
   },
   {
      "id":89569,
      "label":"75",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/89569" 
   },
   {
      "id":92687,
      "label":"Bit",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/92687" 
   },
   {
      "id":100519,
      "label":"Fdnr_025/1",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/100519" 
   },
   {
      "id":99529,
      "label":"Fund 06_009",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/99529" 
   },
   {
      "id":105927,
      "label":"Fund 07_007",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/105927" 
   },
   {
      "id":101653,
      "label":"Fund 08_027",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/101653" 
   },
   {
      "id":99807,
      "label":"Fund 10_061",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/99807" 
   },
   {
      "id":99813,
      "label":"Fund 11_061",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/99813" 
   },
   {
      "id":102555,
      "label":"Fund 15_107",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/102555" 
   },
   {
      "id":99013,
      "label":"Fund 16_002",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/99013" 
   },
   {
      "id":100725,
      "label":"Fund 20_002",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/100725" 
   },
   {
      "id":107493,
      "label":"Grave01-08",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107493" 
   },
   {
      "id":107517,
      "label":"Grave03-03",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107517" 
   },
   {
      "id":107533,
      "label":"Grave04-10",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107533" 
   },
   {
      "id":107593,
      "label":"Grave07-10",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107593" 
   },
   {
      "id":107641,
      "label":"Grave08-15",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107641" 
   },
   {
      "id":107227,
      "label":"Grave 16-10",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107227" 
   },
   {
      "id":107703,
      "label":"Grave21-01",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107703" 
   },
   {
      "id":107729,
      "label":"Grave22-01",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107729" 
   },
   {
      "id":103655,
      "label":"Grave26-01",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/103655" 
   },
   {
      "id":99321,
      "label":"Inr. 32979a",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/99321" 
   },
   {
      "id":107427,
      "label":"Inr. 32987",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107427" 
   },
   {
      "id":107425,
      "label":"Inr. 32988",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107425" 
   },
   {
      "id":100549,
      "label":"Inv_Nr. I 950",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/100549" 
   },
   {
      "id":100705,
      "label":"D235",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/100705" 
   },
   {
      "id":107873,
      "label":"D301",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107873" 
   },
   {
      "id":101417,
      "label":"Fdnr_024",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/101417" 
   },
   {
      "id":101659,
      "label":"Fund 09_027",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/101659" 
   },
   {
      "id":99859,
      "label":"Fund 18_061",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/99859" 
   },
   {
      "id":99865,
      "label":"Fund 19_061",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/99865" 
   },
   {
      "id":99871,
      "label":"Fund 20_061",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/99871" 
   },
   {
      "id":107489,
      "label":"Grave01-05",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107489" 
   },
   {
      "id":107515,
      "label":"Grave04-12",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107515" 
   },
   {
      "id":134905,
      "label":"Inv. Nr. 2401",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/134905" 
   },
   {
      "id":134908,
      "label":"Inv. Nr. 2401",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/134908" 
   },
   {
      "id":108945,
      "label":"Zaumzeugbeschläge",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/108945" 
   },
   {
      "id":109001,
      "label":"Zaumzeugbeschlag Winter 12.2",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/109001" 
   },
   {
      "id":91435,
      "label":"76",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/91435" 
   },
   {
      "id":82527,
      "label":"77",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/82527" 
   },
   {
      "id":93035,
      "label":"Find 01",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/93035" 
   },
   {
      "id":93391,
      "label":"Find01",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/93391" 
   },
   {
      "id":93313,
      "label":"Find 03",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/93313" 
   },
   {
      "id":93439,
      "label":"Find 06",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/93439" 
   },
   {
      "id":82181,
      "label":"noname",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/82181" 
   },
   {
      "id":93041,
      "label":"Find 02",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/93041" 
   },
   {
      "id":82461,
      "label":"2",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/82461" 
   },
   {
      "id":82467,
      "label":"3",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/82467" 
   },
   {
      "id":89467,
      "label":"78",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/89467" 
   },
   {
      "id":108331,
      "label":"A-11.036",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/108331" 
   },
   {
      "id":107967,
      "label":"Beigabe 2",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107967" 
   },
   {
      "id":107969,
      "label":"Beigabe 3",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107969" 
   },
   {
      "id":83461,
      "label":"Find 01",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/83461" 
   },
   {
      "id":93397,
      "label":"Find01",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/93397" 
   },
   {
      "id":92277,
      "label":"Find01",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/92277" 
   },
   {
      "id":132758,
      "label":"Find 011_01",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/132758" 
   },
   {
      "id":83467,
      "label":"Find 02",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/83467" 
   },
   {
      "id":83497,
      "label":"Find 02",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/83497" 
   },
   {
      "id":83503,
      "label":"Find 03",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/83503" 
   },
   {
      "id":89383,
      "label":"Find 04",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/89383" 
   },
   {
      "id":89795,
      "label":"Find25",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/89795" 
   },
   {
      "id":94755,
      "label":"G001S01F06",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/94755" 
   },
   {
      "id":102447,
      "label":"G007F02",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/102447" 
   },
   {
      "id":103213,
      "label":"G007F03",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/103213" 
   },
   {
      "id":102531,
      "label":"G024F04",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/102531" 
   },
   {
      "id":105983,
      "label":"G024F05",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/105983" 
   },
   {
      "id":106019,
      "label":"G047F01",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/106019" 
   },
   {
      "id":106025,
      "label":"G047F02",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/106025" 
   },
   {
      "id":102073,
      "label":"G076S1F02",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/102073" 
   },
   {
      "id":102079,
      "label":"G076S1F04",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/102079" 
   },
   {
      "id":102549,
      "label":"G076S1F06",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/102549" 
   },
   {
      "id":117344,
      "label":"G076S1F07",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/117344" 
   },
   {
      "id":101085,
      "label":"G089F01",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/101085" 
   },
   {
      "id":101091,
      "label":"G089F02",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/101091" 
   },
   {
      "id":103571,
      "label":"G102F01",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/103571" 
   },
   {
      "id":103577,
      "label":"G102F02",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/103577" 
   },
   {
      "id":103605,
      "label":"G106F02",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/103605" 
   },
   {
      "id":103611,
      "label":"G106F03",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/103611" 
   },
   {
      "id":103691,
      "label":"G120F02",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/103691" 
   },
   {
      "id":103697,
      "label":"G120F03",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/103697" 
   },
   {
      "id":97803,
      "label":"G129S1F05",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/97803" 
   },
   {
      "id":102733,
      "label":"G129S1F06",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/102733" 
   },
   {
      "id":103809,
      "label":"G138F01",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/103809" 
   },
   {
      "id":103821,
      "label":"G138F02",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/103821" 
   },
   {
      "id":103869,
      "label":"G142F01",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/103869" 
   },
   {
      "id":103761,
      "label":"G142F02",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/103761" 
   },
   {
      "id":103893,
      "label":"G148F03",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/103893" 
   },
   {
      "id":106079,
      "label":"G148F04",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/106079" 
   },
   {
      "id":106109,
      "label":"G154F06",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/106109" 
   },
   {
      "id":102763,
      "label":"G154F07",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/102763" 
   },
   {
      "id":106133,
      "label":"G156F03",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/106133" 
   },
   {
      "id":102793,
      "label":"G156F04",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/102793" 
   },
   {
      "id":104031,
      "label":"G163F01",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104031" 
   },
   {
      "id":98977,
      "label":"G163F02",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/98977" 
   },
   {
      "id":102829,
      "label":"G167S1F03",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/102829" 
   },
   {
      "id":97893,
      "label":"G167S1F04",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/97893" 
   },
   {
      "id":104049,
      "label":"G169F02",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104049" 
   },
   {
      "id":101363,
      "label":"G169F03",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/101363" 
   },
   {
      "id":104097,
      "label":"G174F11",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104097" 
   },
   {
      "id":104073,
      "label":"G174F12",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104073" 
   },
   {
      "id":104205,
      "label":"G185F06",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104205" 
   },
   {
      "id":104211,
      "label":"G185F07",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104211" 
   },
   {
      "id":97911,
      "label":"G187S1F01",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/97911" 
   },
   {
      "id":102409,
      "label":"G187S1F02",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/102409" 
   },
   {
      "id":104257,
      "label":"G194F02",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104257" 
   },
   {
      "id":104169,
      "label":"G194F03",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104169" 
   },
   {
      "id":104353,
      "label":"G205F12",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104353" 
   },
   {
      "id":104227,
      "label":"G205F13",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104227" 
   },
   {
      "id":104441,
      "label":"G225F01",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104441" 
   },
   {
      "id":104447,
      "label":"G225F02",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104447" 
   },
   {
      "id":104519,
      "label":"G230F06",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104519" 
   },
   {
      "id":104525,
      "label":"G230F07",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104525" 
   },
   {
      "id":104567,
      "label":"G239F01",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104567" 
   },
   {
      "id":104573,
      "label":"G239F02",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104573" 
   },
   {
      "id":104629,
      "label":"G244F01",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104629" 
   },
   {
      "id":104635,
      "label":"G244F02",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104635" 
   },
   {
      "id":104659,
      "label":"G246F01",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104659" 
   },
   {
      "id":104665,
      "label":"G246F02",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104665" 
   },
   {
      "id":100635,
      "label":"G261F02",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/100635" 
   },
   {
      "id":100629,
      "label":"G261F03",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/100629" 
   },
   {
      "id":104885,
      "label":"G269F08",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104885" 
   },
   {
      "id":104891,
      "label":"G269F09",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104891" 
   },
   {
      "id":106175,
      "label":"G277F01",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/106175" 
   },
   {
      "id":106181,
      "label":"G277F02",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/106181" 
   },
   {
      "id":104993,
      "label":"G280F02",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104993" 
   },
   {
      "id":105005,
      "label":"G280F03",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/105005" 
   },
   {
      "id":101633,
      "label":"G286F02",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/101633" 
   },
   {
      "id":105077,
      "label":"G286F03",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/105077" 
   },
   {
      "id":101621,
      "label":"G296F03",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/101621" 
   },
   {
      "id":105699,
      "label":"G296F04",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/105699" 
   },
   {
      "id":105311,
      "label":"G329F03",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/105311" 
   },
   {
      "id":105317,
      "label":"G329F04",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/105317" 
   },
   {
      "id":105183,
      "label":"G338F02",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/105183" 
   },
   {
      "id":105273,
      "label":"G338F03",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/105273" 
   },
   {
      "id":105551,
      "label":"G343F03",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/105551" 
   },
   {
      "id":101887,
      "label":"G375F05",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/101887" 
   },
   {
      "id":101893,
      "label":"G375F06",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/101893" 
   },
   {
      "id":106519,
      "label":"Hemmaberg Sporn 1",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/106519" 
   },
   {
      "id":106525,
      "label":"Hemmaberg Sporn 2",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/106525" 
   },
   {
      "id":106483,
      "label":"Hohenau Inv. No. 140d 1",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/106483" 
   },
   {
      "id":106495,
      "label":"Hohenau Inv. No. 140d 2",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/106495" 
   },
   {
      "id":125705,
      "label":"Inv.A-10.104",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/125705" 
   },
   {
      "id":125751,
      "label":"Inv.A-10.112",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/125751" 
   },
   {
      "id":122736,
      "label":"Inv.A-10.212",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/122736" 
   },
   {
      "id":106359,
      "label":"Inv. No. 9289",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/106359" 
   },
   {
      "id":106363,
      "label":"Inv. No. 9290",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/106363" 
   },
   {
      "id":106361,
      "label":"Inv. No. 9291",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/106361" 
   },
   {
      "id":117578,
      "label":"Iron gilded spurs without inv. no.",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/117578" 
   },
   {
      "id":116658,
      "label":"Iron spurs without inv. no.",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/116658" 
   },
   {
      "id":117790,
      "label":"Iron spurs without inv. no.",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/117790" 
   },
   {
      "id":116427,
      "label":"Iron spur without inv. no.",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/116427" 
   },
   {
      "id":116429,
      "label":"Iron spur without inv. no.",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/116429" 
   },
   {
      "id":83227,
      "label":"No Inv. No.",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/83227" 
   },
   {
      "id":83221,
      "label":"No Inv. No.",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/83221" 
   },
   {
      "id":82491,
      "label":"noname",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/82491" 
   },
   {
      "id":92929,
      "label":"noname",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/92929" 
   },
   {
      "id":117744,
      "label":"Pair of iron spurs",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/117744" 
   },
   {
      "id":100907,
      "label":"Reitersporn (Nietplättchensporn)",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/100907" 
   },
   {
      "id":81867,
      "label":"Sporen In.N.31972/1-13",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/81867" 
   },
   {
      "id":108465,
      "label":"Sporn",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/108465" 
   },
   {
      "id":108463,
      "label":"Sporn",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/108463" 
   },
   {
      "id":106759,
      "label":"Sporn",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/106759" 
   },
   {
      "id":107331,
      "label":"Spornfragment",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107331" 
   },
   {
      "id":106499,
      "label":"Spornfund Förk",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/106499" 
   },
   {
      "id":108763,
      "label":"Spur",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/108763" 
   },
   {
      "id":120970,
      "label":"Spur ",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/120970" 
   },
   {
      "id":120965,
      "label":"Spur ",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/120965" 
   },
   {
      "id":101075,
      "label":"Spur fragmented",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/101075" 
   },
   {
      "id":116714,
      "label":"Spurs without inv. no.",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/116714" 
   },
   {
      "id":116459,
      "label":"Spur with a long spike without inv. no.",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/116459" 
   },
   {
      "id":116457,
      "label":"Spur with a long spike without inv. no.",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/116457" 
   },
   {
      "id":116642,
      "label":"Two spurs without in. no.",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/116642" 
   },
   {
      "id":102453,
      "label":"G007F04",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/102453" 
   },
   {
      "id":105947,
      "label":"G007F05",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/105947" 
   },
   {
      "id":105953,
      "label":"G007F06",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/105953" 
   },
   {
      "id":105371,
      "label":"G024F01",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/105371" 
   },
   {
      "id":106031,
      "label":"G047F03_04",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/106031" 
   },
   {
      "id":117341,
      "label":"G076S1F03",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/117341" 
   },
   {
      "id":103623,
      "label":"G106F04",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/103623" 
   },
   {
      "id":103629,
      "label":"G106F05",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/103629" 
   },
   {
      "id":105651,
      "label":"G138F03",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/105651" 
   },
   {
      "id":101021,
      "label":"G138F04",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/101021" 
   },
   {
      "id":103899,
      "label":"G148F05",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/103899" 
   },
   {
      "id":106115,
      "label":"G154F08",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/106115" 
   },
   {
      "id":106121,
      "label":"G154F09",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/106121" 
   },
   {
      "id":103645,
      "label":"G169F04",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/103645" 
   },
   {
      "id":105563,
      "label":"G169F05",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/105563" 
   },
   {
      "id":104127,
      "label":"G174F17",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104127" 
   },
   {
      "id":104121,
      "label":"G174F18",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104121" 
   },
   {
      "id":104199,
      "label":"G185F04",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104199" 
   },
   {
      "id":104193,
      "label":"G185F05",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104193" 
   },
   {
      "id":104175,
      "label":"G194F04",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104175" 
   },
   {
      "id":104263,
      "label":"G194F05",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104263" 
   },
   {
      "id":104453,
      "label":"G225F03",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104453" 
   },
   {
      "id":104435,
      "label":"G225F06",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104435" 
   },
   {
      "id":104531,
      "label":"G230F08",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104531" 
   },
   {
      "id":101483,
      "label":"G230F10",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/101483" 
   },
   {
      "id":104647,
      "label":"G244F03",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104647" 
   },
   {
      "id":104641,
      "label":"G244F04",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104641" 
   },
   {
      "id":104383,
      "label":"G261F04",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104383" 
   },
   {
      "id":104701,
      "label":"G261F05",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104701" 
   },
   {
      "id":104957,
      "label":"G277F03",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104957" 
   },
   {
      "id":104963,
      "label":"G277F04",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104963" 
   },
   {
      "id":104969,
      "label":"G277F05",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104969" 
   },
   {
      "id":104909,
      "label":"G277F06",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104909" 
   },
   {
      "id":105011,
      "label":"G280F04",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/105011" 
   },
   {
      "id":104981,
      "label":"G280F06",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104981" 
   },
   {
      "id":105089,
      "label":"G286F04",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/105089" 
   },
   {
      "id":105095,
      "label":"G286F05",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/105095" 
   },
   {
      "id":101671,
      "label":"G296F05",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/101671" 
   },
   {
      "id":101677,
      "label":"G296F06",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/101677" 
   },
   {
      "id":105323,
      "label":"G329F05",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/105323" 
   },
   {
      "id":105329,
      "label":"G329F08",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/105329" 
   },
   {
      "id":101791,
      "label":"G338F04",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/101791" 
   },
   {
      "id":101785,
      "label":"G338F05",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/101785" 
   },
   {
      "id":101845,
      "label":"G375F07",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/101845" 
   },
   {
      "id":101851,
      "label":"G375F08",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/101851" 
   },
   {
      "id":122739,
      "label":"Inv.A-10.213",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/122739" 
   },
   {
      "id":116425,
      "label":"Part of a spur buckle without inv. no.",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/116425" 
   },
   {
      "id":116423,
      "label":"Part of a spur buckle witout inv. no.",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/116423" 
   },
   {
      "id":116421,
      "label":"Spur buckle without inv. no.",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/116421" 
   },
   {
      "id":105977,
      "label":"G024F02",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/105977" 
   },
   {
      "id":105059,
      "label":"G024F03",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/105059" 
   },
   {
      "id":103703,
      "label":"G120F04",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/103703" 
   },
   {
      "id":104459,
      "label":"G225F04",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104459" 
   },
   {
      "id":101265,
      "label":"G225F07",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/101265" 
   },
   {
      "id":104537,
      "label":"G230F09",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104537" 
   },
   {
      "id":104543,
      "label":"G230F11",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104543" 
   },
   {
      "id":104653,
      "label":"G244F05",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104653" 
   },
   {
      "id":106187,
      "label":"G244F06",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/106187" 
   },
   {
      "id":100647,
      "label":"G261F06",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/100647" 
   },
   {
      "id":101579,
      "label":"G261F07",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/101579" 
   },
   {
      "id":105335,
      "label":"G329F06",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/105335" 
   },
   {
      "id":103183,
      "label":"G329F09",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/103183" 
   },
   {
      "id":104713,
      "label":"G375F09",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104713" 
   },
   {
      "id":105341,
      "label":"G375F10",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/105341" 
   },
   {
      "id":106497,
      "label":"Hohenau Inv. No. 140d 3",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/106497" 
   },
   {
      "id":106489,
      "label":"Hohenau Inv. No. 140d 4",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/106489" 
   },
   {
      "id":95263,
      "label":"noname",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/95263" 
   },
   {
      "id":105921,
      "label":"G007F07",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/105921" 
   },
   {
      "id":101459,
      "label":"G225F05",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/101459" 
   },
   {
      "id":101453,
      "label":"G225F08",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/101453" 
   },
   {
      "id":104819,
      "label":"G261F08",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104819" 
   },
   {
      "id":104825,
      "label":"G261F09",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104825" 
   },
   {
      "id":104951,
      "label":"G277F07",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104951" 
   },
   {
      "id":104975,
      "label":"G277F08",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/104975" 
   },
   {
      "id":105023,
      "label":"G280F05",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/105023" 
   },
   {
      "id":105029,
      "label":"G280F07",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/105029" 
   },
   {
      "id":105353,
      "label":"G329F07",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/105353" 
   },
   {
      "id":101773,
      "label":"G329F10",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/101773" 
   },
   {
      "id":120973,
      "label":"Strap-end",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/120973" 
   },
   {
      "id":100525,
      "label":"Fdnr_022",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/100525" 
   },
   {
      "id":98889,
      "label":"Fdnr_025/2",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/98889" 
   },
   {
      "id":99523,
      "label":"Fund 03_009",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/99523" 
   },
   {
      "id":99409,
      "label":"Fund 04_005",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/99409" 
   },
   {
      "id":99535,
      "label":"Fund 04_009",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/99535" 
   },
   {
      "id":101647,
      "label":"Fund 07_027",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/101647" 
   },
   {
      "id":99731,
      "label":"Fund 07_060",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/99731" 
   },
   {
      "id":99277,
      "label":"Fund 07a_001",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/99277" 
   },
   {
      "id":109061,
      "label":"Fund 07b_001",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/109061" 
   },
   {
      "id":99737,
      "label":"Fund 08_060",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/99737" 
   },
   {
      "id":108861,
      "label":"Fund 09_011",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/108861" 
   },
   {
      "id":99819,
      "label":"Fund 12_061",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/99819" 
   },
   {
      "id":99831,
      "label":"Fund 13_061",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/99831" 
   },
   {
      "id":99981,
      "label":"Fund 13_107",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/99981" 
   },
   {
      "id":99987,
      "label":"Fund 14_107",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/99987" 
   },
   {
      "id":99067,
      "label":"Fund 20_001",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/99067" 
   },
   {
      "id":107485,
      "label":"Grave01-07",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107485" 
   },
   {
      "id":107507,
      "label":"Grave03-02",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107507" 
   },
   {
      "id":107535,
      "label":"Grave04-11",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107535" 
   },
   {
      "id":107591,
      "label":"Grave07-08",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107591" 
   },
   {
      "id":107657,
      "label":"Grave16-08",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107657" 
   },
   {
      "id":107711,
      "label":"Grave21-02",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107711" 
   },
   {
      "id":107731,
      "label":"Grave22-01",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107731" 
   },
   {
      "id":107801,
      "label":"Grave26-02",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107801" 
   },
   {
      "id":107433,
      "label":"Inr. 32991",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107433" 
   },
   {
      "id":107429,
      "label":"Inr. 32991",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107429" 
   },
   {
      "id":107435,
      "label":"Inr. 32992",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107435" 
   },
   {
      "id":107915,
      "label":"Inr. 32993",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107915" 
   },
   {
      "id":107431,
      "label":"Inr. 32994",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/107431" 
   },
   {
      "id":134899,
      "label":"Inv. Nr. 2402",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/134899" 
   },
   {
      "id":134901,
      "label":"Inv. Nr. 2403",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/134901" 
   },
   {
      "id":108795,
      "label":"Inv_Nr. 950 (Steigbügel)",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/108795" 
   },
   {
      "id":100555,
      "label":"Inv_Nr. I 951",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/100555" 
   },
   {
      "id":83343,
      "label":"Lamprechtskogel Steigbügel",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/83343" 
   },
   {
      "id":108831,
      "label":"Oldfind30",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/108831" 
   },
   {
      "id":83455,
      "label":"Urlaken",
      "relation":"http://openatlas.sarfstation.de/api/0.1/entity/83455" 
   }
]

#11

Updated by Stefan Eichert about 1 month ago

Exactly what we discussed! Thx!

#12

Updated by Bernhard Koschicek about 1 month ago

In the feature_api_node branch, it is now possible to do the same thing with places/subunit. /api/0.1/stratographic_node/50505 returns the first level of subunits, /api/0.1/subunit_hierarchy/50505 returns all subunits, which can be quite time-consuming on places like Thunau.

#13

Updated by Bernhard Koschicek about 1 month ago

  • Target version changed from API to 5.5.0
  • Status changed from Assigned to Closed

I see this ticket as closed. Please make a new ticket if errors occur or other functions are needed.

#14

Updated by Alexander Watzinger about 1 month ago

  • Subject changed from API: also show entities of subtypes to API: Show entities of subtypes

Also available in: Atom PDF