Project

General

Profile

Bug #1614

Custom folders in uploads causing errors

Added by Stefan Eichert 10 months ago. Updated 10 months ago.

Status:
Closed
Priority:
Normal
Category:
Backend
Target version:
Start date:
2021-11-26
Estimated time:
Found in version:

Description

What was original reported as a bug in the orphan view turned out to be a situation created by a custom THANADOS script which created a folder in uploads to be used in the custom presentation site.
Although the quick fix was to simple skip directories in the orphan file function it raises the question, if creating custom folders in uploads is the right approach. A better location may be in /instance because it isn't git tracked either but also don't interferes there with other parts of the application. We should discuss this.

Original report
Internal Server Error when checking Orphans
When I check for Orphans in the THANADOS instance i get an Internal Server Error

History

#1

Updated by Alexander Watzinger 10 months ago

  • Tracker changed from Bug to Feature
  • Subject changed from Internal Server Error when checking Orphans to Allow custom folders in uploads?
  • Description updated (diff)
  • Category set to Backend
  • Status changed from New to Assigned
  • Assignee set to Bernhard Koschiček-Krombholz
  • Target version set to 7.0.0
  • Found in version deleted (6.5.2)

Solved the broken orphan view with skipping directories in the orphan file function in develop and online at THANADOS with a hot fix. We should discuss this in general (see description).
Assigning this to Bernhard to check if custom folders in /uploads can create issues for the image manipulation functions (maybe skip directories there too if needed).
Once checked please assign it back to me so that I can keep an eye on this issue.

#2

Updated by Bernhard Koschiček-Krombholz 10 months ago

  • Assignee changed from Bernhard Koschiček-Krombholz to Alexander Watzinger

It seems to have no effect on image processing. Reassigning it to Alex for overwatch.

#3

Updated by Alexander Watzinger 10 months ago

  • Tracker changed from Feature to Bug
  • Subject changed from Allow custom folders in uploads? to Custom folders in uploads causing errors
  • Status changed from Assigned to Closed
  • Found in version set to 6.5.2

Thank you Bernhard for checking and Stefan for reporting.
Although we fixed/checked that custom folders in openatlas/uploads don't interfere with OpenAtlas functions we strongly recommend that custom scripts (like in the THANADOS project) don't save their files there.
Closing this issue.

Also available in: Atom PDF