Project

General

Profile

Feature #1677

Adding a requirements.txt for alternative installation

Added by Alexander Watzinger about 2 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Category:
Backend
Target version:
Start date:
2022-03-31
Estimated time:

Description

Although extensively testing and documentation is done for installing OpenAtlas on a Linux/Debian system there may be need for installing it in different scenarios.
To make it easier a requirements.txt will be provided in the install folder.

History

#1

Updated by Alexander Watzinger about 2 months ago

This will be an ongoing task. Thank you Bernhard for providing an initial requirement.txt based on your system. I moved it to the install folder and made minor adaptions based on my (Debian/Linux) system.
Andreas Olschnögger can you please take a look/test it too. Although it doesn't have to be immediately for this (7.2.0) version, we can just add a new issue in case you find/suggest something later.

#2

Updated by Bernhard Koschiček-Krombholz about 2 months ago

Typically, the requirements.txt is located in the root directory. Applications will not be able to find/scan it in the /install directory. So an automatic installation of the packages will not be available. But I understand your desire to keep the root directory clean.

I changed one package and added one:

flask-babel from 0.12.0 to 1.0.0

The reason for that is this error message:
ImportError: cannot import name 'ImmutableDict' from 'werkzeug' (C:\Users\bkoschicek\Desktop\OpenAtlas\archive venv\test_venv\lib\site-packages\werkzeug\__init__.py)

I don't know why it works on your machine, but also a lot of people has this issue with werkzeug 1.0.1 and babel < 1.0.0. It is also possible to downgrade werkzeug to 0.16.1, but I think, using the right werkzeug version is more important than using the right babel version.

Added rdflib-jsonld

If we use the rdflib 5.0.0 instead of 6.0.1 we need another package: rdflib-jsonld==0.5.0. rdflib 6.0.1 included the rdflib-jsonld features and since we only have one graph serilization, I thought it would be safe for development enviroments to use 6.0.1. But since it works with both packages, let's keep it that way

#3

Updated by Alexander Watzinger about 2 months ago

File location
Good point, I moved it back to root.

Version changes
This also sounds fine, I expected this will be an ongoing issue and the more feedback for adaptions we get the better.

File encoding
When doing a git diff for the last commit, git wouldn't show telling it's a binary. Not sure what happened there but turned out encoding was set to UTF-16 so I changed it to UTF-8 and now it works as expected.

File structure
I sorted the list alphabetically which looks more readable

Thank you Bernhard for starting this process, looks like we getting somewhere :)

#4

Updated by Alexander Watzinger about 2 months ago

  • Status changed from Assigned to Closed
  • Target version changed from 7.3.0 to 7.2.0

Closing this issue for the 7.2.0 but please Bernhard try to keep an eye on this, maybe Andi can test it too at some point.
If you notice something that should be tracked in an issue please open a new one.
Thanks again Bernhard for starting this process. A requirement.txt was often requested and I'm sure it's very helpful for alternative installation methods.

Also available in: Atom PDF