Project

General

Profile

Bug #1867

Sort issue at first column of form field tables

Added by Alexander Watzinger 22 days ago. Updated 18 days ago.

Status:
Closed
Priority:
Normal
Category:
UI
Target version:
Start date:
2022-11-10
Estimated time:
Found in version:

Description

I noticed a strange issue when trying to sort the first column of form field tables. See e.g.: https://demo.openatlas.eu/insert/artifact when selecting a place.
Other columns seem to work fine and also when looking at e.g. the place overview, sorting the first column works.
I'm not sure what the issue is exactly but would guess it has to do with the links in the first column.

History

#1

Updated by Alexander Watzinger 22 days ago

  • Subject changed from Table sort issue in first column of table form fields to Table sort issue at first column of form field tables
#2

Updated by Alexander Watzinger 22 days ago

  • Subject changed from Table sort issue at first column of form field tables to Sort issue at first column of form field tables
#3

Updated by Andreas Olschnögger 18 days ago

  • Status changed from Assigned to Closed

Thanks for reporting.
This bug occurs because inside the first column there is not only the name but a link with the id. Therefore it was sorted by the id of the entity instead of the name.
The bug is now fixed and already on the develop branch above.

Also available in: Atom PDF