Project

General

Profile

Actions

Bug #2049

closed

Link from Source to Artifact broken

Added by Victoria Leonard 8 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Normal
Category:
Backend
Target version:
Start date:
2023-08-23
Estimated time:
Found in version:

Description

Hello!

I'm not sure if I can use this to feedback to you anymore, sad!

I wanted to add links from four sources to four artifacts, but I got the 'bad request' response. Is it possible to make this change still?

I wanted to add the artifacts for 'Epistula 60++ Augustine to Nectarius' and 'Epistula 61++ Augustine to Nectarius' to the source for 'Epistula 90 Nectarius to Augustine (ca. 408)'.

I wanted to add the artifacts for 'Epistula 62++ Augustine to Crispinus 1' and 'Epistula 63++ Augustine to Crispinus 1' to the source for 'Epistula 51 Augustine to Crispinus 1 (ca. 399-400)'.

Finally, I wanted to add the artifact for 'Epistula 64+ Augustine to Severus 1 (ca. 409)' to the source for 'Epistula 110 Augustine to Severus 1 (ca. 409)'.

Would this be possible?

Many thanks,

with warmest wishes,

Victoria


Files

source_artifact_bug.jpg (29.7 KB) source_artifact_bug.jpg Bernhard Koschiček-Krombholz, 2023-08-24 08:53
source_artifact_bug.jpg (29.7 KB) source_artifact_bug.jpg Bug Bernhard Koschiček-Krombholz, 2023-08-24 10:10
source_to_artifact.jpg (71.9 KB) source_to_artifact.jpg Edit source to add artifact Bernhard Koschiček-Krombholz, 2023-08-24 10:10
Actions #1

Updated by Bernhard Koschiček-Krombholz 8 months ago

  • File source_artifact_bug.jpg source_artifact_bug.jpg added
  • Tracker changed from Question to Bug
  • Subject changed from Adding 4 Artifacts to Sources to Link from Source to Artifact broken
  • Category set to Backend
  • Status changed from New to Acknowledged
  • Target version set to 7.16.0
  • Found in version set to 7.15.0

Updated by Bernhard Koschiček-Krombholz 8 months ago

Dear Victoria, good to hear from you.
I can confirm there is an Add subunit button, which will not work. If the artifact is added with this button, the error page 400 Bad Request: invalid CIDOC link E33 > P46 > E22 appears (so the validation works). Same problem with actors and references. Creation of new artifact through source, actor, reference works as it should be and is correctly linked.

That this button appear is clearly a bug, and we will fix it, thank you!

Either way, the correct way to add an artifact to a source is, that you have to edit the source, and there is a field with the name Artifact, where you can select the wanted artifacts.

Actions #3

Updated by Bernhard Koschiček-Krombholz 8 months ago

  • Assignee set to Bernhard Koschiček-Krombholz
Actions #4

Updated by Bernhard Koschiček-Krombholz 8 months ago

  • Status changed from Acknowledged to Closed

Bug is fixed in develop.

@Victoria Leonard Since Alex is right now not available and this bug will not lead to a broken application or invalid data, I will not update your instance to a development version.

The correct way to add an artifact to a source is, that you have to edit the source, and there is a field with the name Artifact, where you can select and add the wanted artifacts.

Thanks again for reporting this bug!

Actions #5

Updated by Alexander Watzinger 8 months ago

Dear Victoria,
I'm back from vacation and thank you too for reporting this bug and also Bernhard for taking care of it.
You can always, and even are encouraged to, report issues here at the OpenAtlas Redmine.

As Bernhard mentioned, the right way to add artifacts to a source is via editing the source. You find more information in this manual section: https://manual.openatlas.eu/entity/source.html

Please let us know in case of questions and again thank you for reporting the invalid button and Bernhard for fixing it.

Actions

Also available in: Atom PDF