Project

General

Profile

Actions

Bug #2051

closed

Wrong direction for P9

Added by Stefan Eichert 6 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Normal
Category:
CRM
Target version:
Start date:
2023-08-25
Estimated time:
Found in version:

Description

If I am not wrong, similar to https://redmine.craws.net/issues/2007, the direction of/for P9 seems to reversed. The superevent is linked to the subevent by: P9 - "forms part of" but it should be the other way round: "consists of"

Actions #1

Updated by Alexander Watzinger 6 months ago

  • Category set to CRM
  • Status changed from New to Assigned
  • Assignee set to Alexander Watzinger
  • Target version set to 7.16.0
  • Found in version set to 7.15.0

I can confirm this and will fix it in the user interface and also provide SQL update statements to fix existing data.
Because an SQL upgrade will be involved it will be released with the next minor version (7.16.0).

Thanks a lot for reporting this :)

Actions #2

Updated by Alexander Watzinger 6 months ago

  • Status changed from Assigned to In Progress
Actions #3

Updated by Alexander Watzinger 6 months ago

  • Status changed from In Progress to Closed

It is now fixed in the develop version including a database upgrade to fix existing links.
Thanks again Stefan for noticing and reporting it.

Actions

Also available in: Atom PDF