Project

General

Profile

Actions

Bug #2278

closed

Import Place Hierarchy

Added by Lisa Aldrian about 1 month ago. Updated 5 days ago.

Status:
Closed
Priority:
Normal
Category:
Data import/export
Target version:
Start date:
2024-05-14
Estimated time:
Found in version:
Cooperation:
NHM

Description

Importing the attached .csv file results in "Import Error".

Having a string as ID results in "warning-invalid type ids".


Files

st_bol_place_hierarchy.csv (493 KB) st_bol_place_hierarchy.csv invalid type ids Stefan Eichert, 2024-05-14 11:45
st_bol_place_hierarchy.csv (493 KB) st_bol_place_hierarchy.csv import error Stefan Eichert, 2024-05-14 11:46
Actions #2

Updated by Alexander Watzinger about 1 month ago

  • Status changed from New to Assigned
  • Assignee set to Bernhard Koschiček-Krombholz
  • Target version set to 8.5.0

Thank you for reporting and especially for adding some sample files.
I assigned it to @Bernhard Koschiček-Krombholz, kindly asking him to look into it.

Actions #3

Updated by Bernhard Koschiček-Krombholz about 1 month ago

I will look into it. The problem is, that the import use the id field as type_ids field.

Actions #4

Updated by Bernhard Koschiček-Krombholz about 1 month ago

  • Status changed from Assigned to Closed

I fixed the bug(s). It was mostly a typing problem, that sometimes pandas decided the IDs are integers and sometimes strings. Tomorrow I will update Thanados.

Although another thing caught my attention: the coordinates of the geometries is not supported, e.g. POINT (476630.144477715 5560339.71315351). If I put it in something like https://www.geometrymapper.com/, it is on the edge of the map.

Thank you for testing/using and reporting it!

Actions #5

Updated by Alexander Watzinger 5 days ago

  • Cooperation bITEM added
Actions #6

Updated by Alexander Watzinger 5 days ago

  • Cooperation NHM added
  • Cooperation deleted (bITEM)
Actions

Also available in: Atom PDF