Project

General

Profile

Actions

Feature #1796

closed

Improved search

Added by Andreas Olschnögger almost 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Target version:
Start date:
2022-08-29
Estimated time:

Description

To improve the search functionality we thought about folllowing changes:
  • show the table with the data first instead of the map
  • merge search results for artifacts and places

Files


Related issues 1 (0 open1 closed)

Related to OpenAtlas - Bug #1912: API: search for typeID with subs logically connected with ANDClosedBernhard Koschiček-Krombholz2022-12-13Actions
Actions #1

Updated by Andreas Olschnögger almost 2 years ago

  • Subject changed from Search: table as default view to Improved search
  • Description updated (diff)
Actions #2

Updated by Andreas Olschnögger over 1 year ago

  • Status changed from Assigned to Resolved
  • Assignee changed from Andreas Olschnögger to Natasha Kimmet

The search function is now improved. There is no distinction between places and artifacts anymore when filtering.
Also the filter window will now only open on a click on the filer icon or when typing to avoid confusion when clicking on the text inside the search bar.
@Natasha Kimmet please have a look at the new search functionality.
If you find any issues or you have some suggestions for improvements please reassign the ticket to me.
Otherwise if everything is okay for you you can close the ticket.
https://shahi.acdh-dev.oeaw.ac.at/

Actions #3

Updated by Gosia Lenko over 1 year ago

Dear all,
I was able to work with the frontend quite well 10 days ago. Now I am not able search (therefore cannot really say anything about the improved search), explore the map, enter any tab from the toolbar, etc. All I get is the upper and bottom part of the site, no content - screenshot included.
Is it caused by the fact that you are currently working on the frontend or is there any problem (eventually on my site?) ?

Actions #4

Updated by Alexander Watzinger over 1 year ago

Dear Goisa,

I'm not directly involved in the site development and also wasn't able to open the screenshot file because it is a "Apple Safari WebArchive" file, which I guess can only be opened with a Mac.
However, I just tested the site myself and map, search, ... works fine, e.g. https://shahi.acdh-dev.oeaw.ac.at/data/map?view_classes=place&view_classes=artifact. Maybe you have to refresh the site (clear the browser cache), not sure how to do it with Safari but in Firefox it can be done with Strg + F5.
Can you also try a different browser? Safari is well known for long outstanding bugs that they can't or do not want to fix.

Actions #5

Updated by Gosia Lenko over 1 year ago

Alexander Watzinger wrote:

Dear Goisa,

I'm not directly involved in the site development and also wasn't able to open the screenshot file because it is a "Apple Safari WebArchive" file, which I guess can only be opened with a Mac.
However, I just tested the site myself and map, search, ... works fine, e.g. https://shahi.acdh-dev.oeaw.ac.at/data/map?view_classes=place&view_classes=artifact. Maybe you have to refresh the site (clear the browser cache), not sure how to do it with Safari but in Firefox it can be done with Strg + F5.
Can you also try a different browser? Safari is well known for long outstanding bugs that they can't or do not want to fix.

Dear Alex, thank you for your response and recommendations! I was able to open the page correctly via Google chrome, so it indeed has been a problem on my end.

Actions #6

Updated by Andreas Olschnögger over 1 year ago

  • Assignee changed from Andreas Olschnögger to Gosia Lenko

Dear Gosia
thanks for reporting the error, I have now tested it on Firefox, Chrome, Edge and Safari for me as well, everything seems to work. Could you please tell me which browsers with which version you used?

I'll assign the ticket to you again. If you could temporarily use Chrome to take a look at the search improvements I would appreciate it.

Actions #7

Updated by Gosia Lenko over 1 year ago

  • Assignee changed from Gosia Lenko to Andreas Olschnögger

Dear Andreas,
I was using Safari 14.1.2, but it works perfectly with Chrome so I can just use that. Just good to know that it was my internal problem and not one of the website. Thank you for the feedback!

Actions #8

Updated by Gosia Lenko over 1 year ago

Dear Andreas, thank you for impriving the search option. We tried it out and it makes a good impression - I still do struggle sometimes but I guess one just need to get used to it.

We would have only one request re: the option "connecting the filters logically" - the option "and" should be the default one. So if one searches for more categories at the same time, the default search result shoul be the one which inludes all searched terms. Thank you!

Actions #9

Updated by Alexander Watzinger over 1 year ago

  • Related to Bug #1912: API: search for typeID with subs logically connected with AND added
Actions #10

Updated by Alexander Watzinger over 1 year ago

  • Status changed from Resolved to In Progress

We found one bug (#1912) concerning the search, sadly Bernhard, our API developer, is on vacation at the moment but we will finish this issue, once the bug is fixed.

Actions #11

Updated by Alexander Watzinger over 1 year ago

  • Target version deleted (Shahi)
Actions #12

Updated by Alexander Watzinger over 1 year ago

  • Project changed from OpenAtlasDiscovery (origin) to OpenAtlas Discovery

@ Developers: moving this issue to the new system OpenAtlas Discovery to move on because it's the last open issue of the former system.
That way we can close the Redmine project of the former frontend system and prevent that e.g. someone accidentally lands there.
In case something else related to the former system comes up we can track it in the new one as well.

Actions #13

Updated by Alexander Watzinger over 1 year ago

  • Subject changed from Improved search to Former frontend: Improved search
Actions #14

Updated by Alexander Watzinger over 1 year ago

Update: with the 7.9.0 release today (already online for Shahi too) the bug blocking this feature (#1912) is fixed. So this issue should now be solvable.

Actions #15

Updated by Andreas Olschnögger over 1 year ago

  • Status changed from In Progress to Closed

The default search now uses the logical 'and' concatenator when searching for multiple types.

Actions #16

Updated by Alexander Watzinger over 1 year ago

  • Project changed from OpenAtlas Discovery to OpenAtlasDiscovery (origin)
  • Target version set to Shahi

Thanks to all involved for solving this issue. I move this issue back to the (already closed) former project version.

Actions #17

Updated by Alexander Watzinger over 1 year ago

  • Subject changed from Former frontend: Improved search to Improved search
Actions

Also available in: Atom PDF