Project

General

Profile

Bug #1188

Missing map in add feature view

Added by Roland Filzwieser 4 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Low
Category:
Maps
Target version:
Start date:
2020-04-03
Estimated time:
Found in version:

Description

When inserting a new feature (e.g. new grave) in insert mode the basemap does not appear, only a gray rectangle and zoom level says "undifined". After inserting the feature, the map is displayed normally in edit mode.

History

#1

Updated by Alexander Watzinger 4 months ago

  • Target version set to 5.2.0
  • Assignee set to Alexander Watzinger
  • Status changed from New to Acknowledged
  • Category set to Maps
  • Subject changed from no map in + Feature to No map in add feature view
  • Project changed from THANADOS to OpenAtlas

It seem to occur if the parent element has no geographic feature, e.g. on https://thanados.openatlas.eu/place/insert/125358 it throws an JavaScript error

map.js:255 Uncaught ReferenceError: pointSupersLayer is not defined
Strangely it only happens on Thanados and I couldn't reproduce it on another system but I will look into it.

Thank you for reporting but 2 minor suggestions:
  • Please report OpenAtlas bugs in the OpenAtlas project (I already moved it) because Thanados is for the presentation site and also not public so it could get missed e.g by our frontend developer
  • Providing an URL (like I've already done in this note) would be very helpful for reproducing errors
#2

Updated by Alexander Watzinger 4 months ago

  • Status changed from Acknowledged to In Progress
#3

Updated by Alexander Watzinger 4 months ago

  • Assignee changed from Alexander Watzinger to Stefan Eichert
  • Status changed from In Progress to Assigned

Turned out there is a problem when trying to focus the map (implemented by Christoph) with using super layers (implemented by Stefan).

I implemented a quick fix, pushed it online and should work for now (don't forget to refresh browser). You also got the new feature files for types #991 at this occasion.

@ Stefan, this is just a quick solution so that people can continue to work but I suspect a deeper issue, see https://github.com/craws/OpenAtlas/commit/dd0a7ab42bda03042c527e00c8028cd8a198d500 were I changed

if (gisPointSupers != '') allSelected.push(pointSupersLayer);
to
if (gisPointSupers != '' && typeof pointSupersLayer != "undefined") allSelected.push(pointSupersLayer);

because gisPointSupers is set (an object) but pointSupersLayers is undefined. Can you please look into it (develop branch) and adapt code if necessary. Feel free to ask if more info is needed.

#4

Updated by Stefan Eichert 4 months ago

  • Status changed from Assigned to Closed

Pushed to fix_Bug #1188 branch

#5

Updated by Alexander Watzinger 4 months ago

  • Found in version set to 5.0.0
  • Subject changed from No map in add feature view to Missing map in add feature view

Thanks Stefan, already merged in develop so you can delete your locale fix branch.

#6

Updated by Alexander Watzinger 4 months ago

  • Target version changed from 5.2.0 to 5.1.0

Also available in: Atom PDF